What’s Vulnerable › Vulnerabilities

CVE-2023-27492: Envoy may crash when a large request body is processed in Lua filter

Description

Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9, the Lua filter is vulnerable to denial of service. Attackers can send large request bodies for routes that have Lua filter enabled and trigger crashes. As of versions versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9, Envoy no longer invokes the Lua coroutine if the filter has been reset. As a workaround for those whose Lua filter is buffering all requests/ responses, mitigate by using the buffer filter to avoid triggering the local reply in the Lua filter.

Affected products

How to fix

Upgrade to a fixed version: envoyproxy envoy 1.22.9, 1.23.6, 1.24.4, 1.25.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-27492 or the next vulnerability affects your stack