What’s Vulnerable › Vulnerabilities
CVE-2023-27493: Envoy doesn't escape HTTP header values
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-04 · updated 2026-06-17
- Weakness: CWE-20
Description
Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9, Envoy does not sanitize or escape request properties when generating request headers. This can lead to characters that are illegal in header values to be sent to the upstream service. In the worst case, it can cause upstream service to interpret the original request as two pipelined requests, possibly bypassing the intent of Envoy’s security policy. Versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9 contain a patch. As a workaround, disable adding request headers based on the downstream request properties, such as downstream certificate properties.
Affected products
- envoyproxy envoy: before 1.22.9; from 1.23.0 before 1.23.6; from 1.24.0 before 1.24.4; from 1.25.0 before 1.25.3 — fixed in 1.22.9, 1.23.6, 1.24.4, 1.25.3
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.22.9, 1.23.6, 1.24.4, 1.25.3. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-w5w5-487h-qv8q
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-w5w5-487h-qv8q
Get alerted when CVE-2023-27493 or the next vulnerability affects your stack