What’s Vulnerable › Vulnerabilities
CVE-2023-27494: Streamlit Cross-site Scripting vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-16 · updated 2026-06-17
- Weakness: CWE-79
Description
Streamlit, software for turning data scripts into web applications, had a cross-site scripting (XSS) vulnerability in versions 0.63.0 through 0.80.0. Users of hosted Streamlit app(s) were vulnerable to a reflected XSS vulnerability. An attacker could craft a malicious URL with Javascript payloads to a Streamlit app. The attacker could then trick the user into visiting the malicious URL and, if successful, the server would render the malicious javascript payload as-is, leading to XSS. Version 0.81.0 contains a patch for this vulnerability.
Affected products
- streamlit: from 0.63.0 before 0.81.0 — fixed in 0.81.0
How to fix
Upgrade to a fixed version: streamlit 0.81.0. Check the vendor advisory for mitigations.
References
- https://github.com/streamlit/streamlit/commit/afcf880c60e5d7538936cc2d9721b9e1bc02b075
- https://github.com/streamlit/streamlit/security/advisories/GHSA-9c6g-qpgj-rvxw
- https://github.com/streamlit/streamlit/commit/afcf880c60e5d7538936cc2d9721b9e1bc02b075
- https://github.com/streamlit/streamlit/security/advisories/GHSA-9c6g-qpgj-rvxw
Get alerted when CVE-2023-27494 or the next vulnerability affects your stack