What’s Vulnerable › Vulnerabilities
CVE-2023-27522: Apache HTTP Server: mod_proxy_uwsgi HTTP response splitting
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-07 · updated 2026-06-17
- Weakness: CWE-444
Description
HTTP Response Smuggling vulnerability in Apache HTTP Server via mod_proxy_uwsgi. This issue affects Apache HTTP Server: from 2.4.30 through 2.4.55. Special characters in the origin response header can truncate/split the response forwarded to the client.
Affected products
- Apache HTTP Server: from 2.4.30 before 2.4.56 — fixed in 2.4.56
- Debian Linux: 10.0
- Unbit Uwsgi: before 2.0.22 — fixed in 2.0.22
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.56; Unbit Uwsgi 2.0.22. Check the vendor advisory for mitigations.
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- https://lists.debian.org/debian-lts-announce/2023/04/msg00028.html
- https://security.gentoo.org/glsa/202309-01
- https://httpd.apache.org/security/vulnerabilities_24.html
- https://lists.debian.org/debian-lts-announce/2023/04/msg00028.html
- https://security.gentoo.org/glsa/202309-01
Get alerted when CVE-2023-27522 or the next vulnerability affects your stack