What’s Vulnerable › Vulnerabilities
CVE-2023-27539: Possible Denial of Service Vulnerability in Rack's header parsing
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-09 · updated 2026-06-17
Description
There is a denial of service vulnerability in the header parsing component of Rack.
Affected products
- Debian Linux: 10.0, 11.0
- rack: from 2.0.0 before 2.2.6.4; from 3.0.0 before 3.0.6.1 — fixed in 2.2.6.4, 3.0.6.1
- Rubygems Rack: from 2.0.0 before 2.2.6.4; from 3.0.0 before 3.0.6.1; 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6 (+36) — fixed in 2.2.6.4, 3.0.6.1
How to fix
Upgrade to a fixed version: rack 2.2.6.4, 3.0.6.1; Rubygems Rack 2.2.6.4, 3.0.6.1. Check the vendor advisory for mitigations.
References
- https://discuss.rubyonrails.org/t/cve-2023-27539-possible-denial-of-service-vulnerability-in-racks-header-parsing/82466
- https://github.com/advisories/GHSA-c6qg-cjj8-47qp
- https://github.com/rack/rack/commit/231ef369ad0b542575fb36c74fcfcfabcf6c530c
- https://github.com/rack/rack/commit/ee7919ea04303717858be1c3f16b406adc6d8cff
- https://lists.debian.org/debian-lts-announce/2023/04/msg00017.html
- https://security.netapp.com/advisory/ntap-20231208-0016/
- https://www.debian.org/security/2023/dsa-5530
Get alerted when CVE-2023-27539 or the next vulnerability affects your stack