What’s Vulnerable › Vulnerabilities
CVE-2023-27560
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-03 · updated 2026-06-17
- Weakness: CWE-835
Description
Math/PrimeField.php in phpseclib 3.x before 3.0.19 has an infinite loop with composite primefields.
Affected products
- phpseclib: from 3.0.0 before 3.0.19 — fixed in 3.0.19
How to fix
Upgrade to a fixed version: phpseclib 3.0.19. Check the vendor advisory for mitigations.
References
- https://github.com/phpseclib/phpseclib/commit/6298d1cd55c3ffa44533bd41906caec246b60440
- https://github.com/phpseclib/phpseclib/releases/tag/3.0.19
- https://github.com/phpseclib/phpseclib/commit/6298d1cd55c3ffa44533bd41906caec246b60440
- https://github.com/phpseclib/phpseclib/releases/tag/3.0.19
Get alerted when CVE-2023-27560 or the next vulnerability affects your stack