What’s Vulnerable › Vulnerabilities
CVE-2023-27577: Path Traversal Vulnerability in `LESS` Parser allows reading of sensitive server files in flarum
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-10 · updated 2026-06-17
- Weakness: CWE-22
Description
flarum is a forum software package for building communities. In versions prior to 1.7.0 an admin account which has already been compromised by an attacker may use a vulnerability in the `LESS` parser which can be exploited to read sensitive files on the server through the use of path traversal techniques. An attacker can achieve this by providing an absolute path to a sensitive file in the custom `LESS` setting, which the `LESS` parser will then read. For example, an attacker could use the following code to read the contents of the `/etc/passwd` file on a linux machine. The scope of what files are vulnerable will depend on the permissions given to the running flarum process. The vulnerability has been addressed in version `1.7`. Users should upgrade to this version to mitigate the vulnerability. Users unable to upgrade may mitigate the vulnerability by ensuring that their admin accounts are secured with strong passwords and follow other best practices for account security. Additionally, users can limit the exposure of sensitive files on the server by implementing appropriate file permissions and access controls at the operating system level.
Affected products
- Flarum: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: Flarum 1.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/flarum/framework/commit/1761660c98ea5a3e9665fb8e6041d1f2ee62a444
- https://github.com/flarum/framework/security/advisories/GHSA-vhm8-wwrf-3gcw
- https://github.com/flarum/framework/commit/1761660c98ea5a3e9665fb8e6041d1f2ee62a444
- https://github.com/flarum/framework/security/advisories/GHSA-vhm8-wwrf-3gcw
Get alerted when CVE-2023-27577 or the next vulnerability affects your stack