What’s Vulnerable › Vulnerabilities
CVE-2023-27578: Galaxy vulnerable to unauthorized modification of pages/visualizations due to insufficient permission check
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-20 · updated 2026-06-17
- Weakness: CWE-284
Description
Galaxy is an open-source platform for data analysis. All supported versions of Galaxy are affected prior to 22.01, 22.05, and 23.0 are affected by an insufficient permission check. Unsupported versions are likely affected as far back as the functionality of Visualizations/Pages exists. Due to this issue, an attacker can modify or delete any Galaxy Visualization or Galaxy Page given they know the encoded ID of it. Additionally, they can copy or import any Galaxy Visualization given they know the encoded ID of it. Patches are available for versions 22.01, 22.05, and 23.0. For the changes to take effect, you must restart all Galaxy server processes. There are no supported workarounds.
Affected products
- galaxyproject galaxy: before 22.01 — fixed in 22.01
How to fix
Upgrade to a fixed version: galaxyproject galaxy 22.01. Check the vendor advisory for mitigations.
References
- https://depot.galaxyproject.org/patch/GX-2022-0002/modify_pages_viz-release_22.01.patch
- https://depot.galaxyproject.org/patch/GX-2022-0002/modify_pages_viz-release_22.05.patch
- https://depot.galaxyproject.org/patch/GX-2022-0002/modify_pages_viz-release_23.0.patch
- https://github.com/galaxyproject/galaxy/security/advisories/GHSA-j8q2-r4g5-f22j
- https://depot.galaxyproject.org/patch/GX-2022-0002/modify_pages_viz-release_22.01.patch
- https://depot.galaxyproject.org/patch/GX-2022-0002/modify_pages_viz-release_22.05.patch
- https://depot.galaxyproject.org/patch/GX-2022-0002/modify_pages_viz-release_23.0.patch
- https://github.com/galaxyproject/galaxy/security/advisories/GHSA-j8q2-r4g5-f22j
Get alerted when CVE-2023-27578 or the next vulnerability affects your stack