What’s Vulnerable › Vulnerabilities
CVE-2023-27588: Unauthenticated path traversal vulnerability in Hasura GraphQL Engine
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-14 · updated 2026-06-17
- Weakness: CWE-22
Description
Hasura is an open-source product that provides users GraphQL or REST APIs. A path traversal vulnerability has been discovered within Hasura GraphQL Engine prior to versions 1.3.4, 2.55.1, 2.20.1, and 2.21.0-beta1. Projects running on Hasura Cloud were not vulnerable. Self-hosted Hasura Projects with deployments that are publicly exposed and not protected by a WAF or other HTTP protection layer should be upgraded to version 1.3.4, 2.55.1, 2.20.1, or 2.21.0-beta1 to receive a patch.
Affected products
- Hasura GraphQL: before 1.3.4; from 2.0.0 before 2.11.5; from 2.12.0 before 2.20.1 — fixed in 1.3.4, 2.11.5, 2.20.1
How to fix
Upgrade to a fixed version: Hasura GraphQL 1.3.4, 2.11.5, 2.20.1. Check the vendor advisory for mitigations.
References
- https://github.com/hasura/graphql-engine/commit/dda54543ee1ecf647ca5d0971b140c3a7b9f4158
- https://github.com/hasura/graphql-engine/releases/tag/v1.3.4
- https://github.com/hasura/graphql-engine/releases/tag/v2.11.5
- https://github.com/hasura/graphql-engine/releases/tag/v2.20.1
- https://github.com/hasura/graphql-engine/releases/tag/v2.21.0-beta.1
- https://github.com/hasura/graphql-engine/security/advisories/GHSA-c9rw-rw2f-mj4x
- https://github.com/hasura/graphql-engine/commit/dda54543ee1ecf647ca5d0971b140c3a7b9f4158
- https://github.com/hasura/graphql-engine/releases/tag/v1.3.4
- https://github.com/hasura/graphql-engine/releases/tag/v2.11.5
- https://github.com/hasura/graphql-engine/releases/tag/v2.20.1
- https://github.com/hasura/graphql-engine/releases/tag/v2.21.0-beta.1
- https://github.com/hasura/graphql-engine/security/advisories/GHSA-c9rw-rw2f-mj4x
Get alerted when CVE-2023-27588 or the next vulnerability affects your stack