What’s Vulnerable › Vulnerabilities
CVE-2023-27596: OpenSIPS has vulnerability in the codec_delete_XX() functions
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-15 · updated 2026-06-17
- Weakness: CWE-770
Description
OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, OpenSIPS crashes when a malformed SDP body is sent multiple times to an OpenSIPS configuration that makes use of the `stream_process` function. This issue was discovered during coverage guided fuzzing of the function `codec_delete_except_re`. By abusing this vulnerability, an attacker is able to crash the server. It affects configurations containing functions that rely on the affected code, such as the function `codec_delete_except_re`. This issue has been fixed in version 3.1.8 and 3.2.5.
Affected products
- opensips: before 3.1.8; from 3.2.0 before 3.2.5 — fixed in 3.1.8, 3.2.5
How to fix
Upgrade to a fixed version: opensips 3.1.8, 3.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/OpenSIPS/opensips/commit/dd051f8ed5ae3347fb1d556ced3c97822c9d8450
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-3ghx-j39m-cw4f
- https://github.com/OpenSIPS/opensips/commit/dd051f8ed5ae3347fb1d556ced3c97822c9d8450
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-3ghx-j39m-cw4f
Get alerted when CVE-2023-27596 or the next vulnerability affects your stack