What’s Vulnerable › Vulnerabilities
CVE-2023-27597: OpenSIPS has vulnerability in the parse_uri() function
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-15 · updated 2026-06-17
- Weakness: CWE-20
Description
OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, when a specially crafted SIP message is processed by the function `rewrite_ruri`, a crash occurs due to a segmentation fault. This issue causes the server to crash. It affects configurations containing functions that make use of the affected code, such as the function `setport`. This issue has been fixed in version 3.1.8 and 3.2.5.
Affected products
- opensips: before 3.1.8; from 3.2.0 before 3.2.5 — fixed in 3.1.8, 3.2.5
How to fix
Upgrade to a fixed version: opensips 3.1.8, 3.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/OpenSIPS/opensips/commit/b2dffe4b5cd81182c9c8eabb6c96aac96c7acfe3
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-358f-935m-7p9c
- https://github.com/OpenSIPS/opensips/commit/b2dffe4b5cd81182c9c8eabb6c96aac96c7acfe3
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-358f-935m-7p9c
Get alerted when CVE-2023-27597 or the next vulnerability affects your stack