What’s Vulnerable › Vulnerabilities
CVE-2023-27599: OpenSIPS has vulnerability in the parse_to_param() function
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-15 · updated 2026-06-17
- Weakness: CWE-20
Description
OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.7 and 3.2.4, when the function `append_hf` handles a SIP message with a malformed To header, a call to the function `abort()` is performed, resulting in a crash. This is due to the following check in `data_lump.c:399` in the function `anchor_lump`. An attacker abusing this vulnerability will crash OpenSIPS leading to Denial of Service. It affects configurations containing functions that make use of the affected code, such as the function `append_hf`. This issue has been fixed in versions 3.1.7 and 3.2.4.
Affected products
- opensips: before 3.1.7; from 3.2.0 before 3.2.4 — fixed in 3.1.7, 3.2.4
How to fix
Upgrade to a fixed version: opensips 3.1.7, 3.2.4. Check the vendor advisory for mitigations.
References
- https://github.com/OpenSIPS/opensips/commit/cb56694d290530ac308f44b453c18120b1c1109d
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-qvj2-vqrg-f5jx
- https://opensips.org/pub/audit-2022/opensips-audit-technical-report-full.pdf
- https://github.com/OpenSIPS/opensips/commit/cb56694d290530ac308f44b453c18120b1c1109d
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-qvj2-vqrg-f5jx
- https://opensips.org/pub/audit-2022/opensips-audit-technical-report-full.pdf
Get alerted when CVE-2023-27599 or the next vulnerability affects your stack