What’s Vulnerable › Vulnerabilities
CVE-2023-27600: OpenSIPS has vulnerability in the codec_delete_XX() functions
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-15 · updated 2026-06-17
- Weakness: CWE-20
Description
OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.7 and 3.2.4, OpenSIPS crashes when a malformed SDP body is received and is processed by the `delete_sdp_line` function in the sipmsgops module. This issue can be reproduced by calling the function with an SDP body that does not terminate by a line feed (i.e. `\n`). The vulnerability was found while performing black-box fuzzing against an OpenSIPS server running a configuration that made use of the functions `codec_delete_except_re` and `codec_delete_re`. The same issue was also discovered while performing coverage guided fuzzing on the function `codec_delete_except_re`. The crash happens because the function `delete_sdp_line` expects that an SDP line is terminated by a line feed (`\n`). By abusing this vulnerability, an attacker is able to crash the server. It affects configurations containing functions that rely on the affected code, such as the function `codec_delete_except_re`. Due to the sanity check that is performed in the `del_lump` function, exploitation of this issue will generate an `abort` in the lumps processing function, resulting in a Denial of Service. This issue is patched in versions 3.1.7 and 3.2.4.
Affected products
- opensips: before 3.1.7; from 3.2.0 before 3.2.4 — fixed in 3.1.7, 3.2.4
How to fix
Upgrade to a fixed version: opensips 3.1.7, 3.2.4. Check the vendor advisory for mitigations.
References
- https://github.com/OpenSIPS/opensips/commit/c6ab3bb406c447e30c7d33a1a8970048b4612100
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-67w7-g4j8-3wcx
- https://opensips.org/docs/modules/3.3.x/sipmsgops.html
- https://opensips.org/pub/audit-2022/opensips-audit-technical-report-full.pdf
- https://github.com/OpenSIPS/opensips/commit/c6ab3bb406c447e30c7d33a1a8970048b4612100
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-67w7-g4j8-3wcx
- https://opensips.org/docs/modules/3.3.x/sipmsgops.html
- https://opensips.org/pub/audit-2022/opensips-audit-technical-report-full.pdf
Get alerted when CVE-2023-27600 or the next vulnerability affects your stack