What’s Vulnerable › Vulnerabilities
CVE-2023-27604: Apache Airflow Sqoop Provider: Airflow Sqoop Provider RCE Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-28 · updated 2026-06-17
- Weakness: CWE-20
Description
Apache Airflow Sqoop Provider, versions before 4.0.0, is affected by a vulnerability that allows an attacker pass parameters with the connections, which makes it possible to implement RCE attacks via ‘sqoop import --connect’, obtain airflow server permissions, etc. The attacker needs to be logged in and have authorization (permissions) to create/edit connections. It is recommended to upgrade to a version that is not affected. This issue was reported independently by happyhacking-k, And Xie Jianming and LiuHui of Caiji Sec Team also reported it.
Affected products
- Apache Airflow Sqoop Provider: before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: Apache Airflow Sqoop Provider 4.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/33039
- https://lists.apache.org/thread/lswlxf11do51ob7f6xyyg8qp3n7wdrgd
- https://github.com/apache/airflow/pull/33039
- https://lists.apache.org/thread/lswlxf11do51ob7f6xyyg8qp3n7wdrgd
Get alerted when CVE-2023-27604 or the next vulnerability affects your stack