What’s Vulnerable › Vulnerabilities
CVE-2023-27830
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-12 · updated 2026-06-17
- Weakness: CWE-269
Description
TightVNC before v2.8.75 allows attackers to escalate privileges on the host operating system via replacing legitimate files with crafted files when executing a file transfer. This is due to the fact that TightVNC runs in the backend as a high-privileges account.
Affected products
- Kaspersky TightVNC: before 2.8.75 — fixed in 2.8.75
How to fix
Upgrade to a fixed version: Kaspersky TightVNC 2.8.75. Check the vendor advisory for mitigations.
References
- https://medium.com/nestedif/vulnerability-disclosure-privilege-escalation-tightvnc-8165208cce
- https://www.tightvnc.com/news.php
- https://www.tightvnc.com/whatsnew.php
- https://medium.com/nestedif/vulnerability-disclosure-privilege-escalation-tightvnc-8165208cce
- https://www.tightvnc.com/news.php
- https://www.tightvnc.com/whatsnew.php
Get alerted when CVE-2023-27830 or the next vulnerability affects your stack