What’s Vulnerable › Vulnerabilities

CVE-2023-27898

Description

Jenkins 2.270 through 2.393 (both inclusive), LTS 2.277.1 through 2.375.3 (both inclusive) does not escape the Jenkins version a plugin depends on when rendering the error message stating its incompatibility with the current version of Jenkins, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide plugins to the configured update sites and have this message shown by Jenkins instances.

Affected products

How to fix

Upgrade to a fixed version: Jenkins 2.375.4, 2.394. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-27898 or the next vulnerability affects your stack