What’s Vulnerable › Vulnerabilities

CVE-2023-27900

Description

Jenkins 2.393 and earlier, LTS 2.375.3 and earlier uses the Apache Commons FileUpload library without specifying limits for the number of request parts introduced in version 1.5 for CVE-2023-24998 in hudson.util.MultipartFormDataParser, allowing attackers to trigger a denial of service.

Affected products

How to fix

Upgrade to a fixed version: Jenkins 2.375.4, 2.394. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-27900 or the next vulnerability affects your stack