What’s Vulnerable › Vulnerabilities
CVE-2023-27901
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-10 · updated 2026-06-17
- Weakness: CWE-770
Description
Jenkins 2.393 and earlier, LTS 2.375.3 and earlier uses the Apache Commons FileUpload library without specifying limits for the number of request parts introduced in version 1.5 for CVE-2023-24998 in org.kohsuke.stapler.RequestImpl, allowing attackers to trigger a denial of service.
Affected products
- Jenkins: before 2.375.4; before 2.394 — fixed in 2.375.4, 2.394
How to fix
Upgrade to a fixed version: Jenkins 2.375.4, 2.394. Check the vendor advisory for mitigations.
References
- https://www.jenkins.io/security/advisory/2023-03-08/#SECURITY-3030
- https://www.jenkins.io/security/advisory/2023-03-08/#SECURITY-3030
Get alerted when CVE-2023-27901 or the next vulnerability affects your stack