What’s Vulnerable › Vulnerabilities

CVE-2023-27904

Description

Jenkins 2.393 and earlier, LTS 2.375.3 and earlier prints an error stack trace on agent-related pages when agent connections are broken, potentially revealing information about Jenkins configuration that is otherwise inaccessible to attackers.

Affected products

How to fix

Upgrade to a fixed version: Jenkins 2.375.4, 2.394. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-27904 or the next vulnerability affects your stack