What’s Vulnerable › Vulnerabilities
CVE-2023-2795: CodeColorer < 0.10.1 – Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-27 · updated 2026-06-17
Description
The CodeColorer WordPress plugin before 0.10.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- CodeColorer: before 0.10.1 — fixed in 0.10.1
How to fix
Upgrade to a fixed version: CodeColorer 0.10.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2d6ecd21-3dd4-423d-80e7-277c45080a9f
- https://wpscan.com/vulnerability/2d6ecd21-3dd4-423d-80e7-277c45080a9f
Get alerted when CVE-2023-2795 or the next vulnerability affects your stack