What’s Vulnerable › Vulnerabilities
CVE-2023-2798: Denial of service in HtmlUnit
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-25 · updated 2026-06-17
- Weakness: CWE-400
Description
Those using HtmlUnit to browse untrusted webpages may be vulnerable to Denial of service attacks (DoS). If HtmlUnit is running on user supplied web pages, an attacker may supply content that causes HtmlUnit to crash by a stack overflow. This effect may support a denial of service attack.This issue affects htmlunit before 2.70.0.
Affected products
- net.sourceforge.htmlunit:htmlunit: before 2.70.0 — fixed in 2.70.0
How to fix
Upgrade to a fixed version: net.sourceforge.htmlunit:htmlunit 2.70.0. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=54613
- https://github.com/HtmlUnit/htmlunit/commit/940dc7fd
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=54613
- https://github.com/HtmlUnit/htmlunit/commit/940dc7fd
Get alerted when CVE-2023-2798 or the next vulnerability affects your stack