What’s Vulnerable › Vulnerabilities
CVE-2023-27988
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-30 · updated 2026-06-17
- Weakness: CWE-78
Description
The post-authentication command injection vulnerability in the Zyxel NAS326 firmware versions prior to V5.21(AAZF.13)C0 could allow an authenticated attacker with administrator privileges to execute some operating system (OS) commands on an affected device remotely.
Affected products
- Zyxel NAS326 firmware: before 5.21\(aazf.13\)c0 — fixed in 5.21\(aazf.13\)c0
- Zyxel NAS540 firmware: before 5.21\(aatb.10\)c0 — fixed in 5.21\(aatb.10\)c0
- Zyxel NAS542 firmware: before 5.21\(abag.10\)c0 — fixed in 5.21\(abag.10\)c0
How to fix
Upgrade to a fixed version: Zyxel NAS326 firmware 5.21\(aazf.13\)c0; Zyxel NAS540 firmware 5.21\(aatb.10\)c0; Zyxel NAS542 firmware 5.21\(abag.10\)c0. Check the vendor advisory for mitigations.
References
- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-post-authentication-command-injection-vulnerability-in-nas-products
- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-post-authentication-command-injection-vulnerability-in-nas-products
Get alerted when CVE-2023-27988 or the next vulnerability affects your stack