What’s Vulnerable › Vulnerabilities
CVE-2023-27992: Zyxel Multiple NAS Devices Command Injection Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2023-06-23
- EPSS: 82.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-19 · updated 2026-06-17
- Weakness: CWE-78
Description
The pre-authentication command injection vulnerability in the Zyxel NAS326 firmware versions prior to V5.21(AAZF.14)C0, NAS540 firmware versions prior to V5.21(AATB.11)C0, and NAS542 firmware versions prior to V5.21(ABAG.11)C0 could allow an unauthenticated attacker to execute some operating system (OS) commands remotely by sending a crafted HTTP request.
Affected products
- Zyxel NAS326 firmware: before 5.21\(aazf.14\)c0 — fixed in 5.21\(aazf.14\)c0
- Zyxel NAS540 firmware: before 5.21\(aatb.11\)c0 — fixed in 5.21\(aatb.11\)c0
- Zyxel NAS542 firmware: before 5.21\(abag.11\)c0 — fixed in 5.21\(abag.11\)c0
How to fix
Upgrade to a fixed version: Zyxel NAS326 firmware 5.21\(aazf.14\)c0; Zyxel NAS540 firmware 5.21\(aatb.11\)c0; Zyxel NAS542 firmware 5.21\(abag.11\)c0. Check the vendor advisory for mitigations.
References
- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-pre-authentication-command-injection-vulnerability-in-nas-products
- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-pre-authentication-command-injection-vulnerability-in-nas-products
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-27992
Get alerted when CVE-2023-27992 or the next vulnerability affects your stack