What’s Vulnerable › Vulnerabilities
CVE-2023-2805: SupportCandy < 3.1.7 - Admin+ SQLi
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-19 · updated 2026-06-17
Description
The SupportCandy WordPress plugin before 3.1.7 does not properly sanitise and escape the agents[] parameter in the set_add_agent_leaves AJAX function before using it in a SQL statement, leading to a SQL injection exploitable by high privilege users such as admin.
Affected products
- SupportCandy: before 3.1.7 — fixed in 3.1.7
How to fix
Upgrade to a fixed version: SupportCandy 3.1.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/bdb75c8c-87e2-4358-ad3b-f4236e9a43c0
- https://wpscan.com/vulnerability/bdb75c8c-87e2-4358-ad3b-f4236e9a43c0
Get alerted when CVE-2023-2805 or the next vulnerability affects your stack