What’s Vulnerable › Vulnerabilities
CVE-2023-28074
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-31 · updated 2026-06-17
- Weakness: CWE-125
Description
Dell BSAFE Crypto-C Micro Edition, version 4.1.5, and Dell BSAFE Micro Edition Suite, versions 4.0 through 4.6.1 and version 5.0, contains an Out-of-bounds Read vulnerability. An unauthenticated attacker with local access could potentially exploit this vulnerability, leading to Information exposure.
Affected products
- Dell Bsafe Crypto-C-Micro-Edition: from 4.0.0 through 4.1.5
- Dell RSA BSAFE MES: from 4.0.0 before 4.6.2; 5.0 — fixed in 4.6.2
How to fix
Upgrade to a fixed version: Dell RSA BSAFE MES 4.6.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-28074 or the next vulnerability affects your stack