What’s Vulnerable › Vulnerabilities
CVE-2023-28078
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-15 · updated 2026-06-17
- Weakness: CWE-923
Description
Dell OS10 Networking Switches running 10.5.2.x and above contain a vulnerability with zeroMQ when VLT is configured. A remote unauthenticated attacker could potentially exploit this vulnerability leading to information disclosure and a possible Denial of Service when a huge number of requests are sent to the switch. This is a high severity vulnerability as it allows an attacker to view sensitive data. Dell recommends customers to upgrade at the earliest opportunity.
Affected products
- Dell SmartFabric OS10 Software: from 10.5.2.0 before 10.5.2.12; from 10.5.3.0 before 10.5.3.8; from 10.5.4.0 before 10.5.4.8; 10.5.5.0, 10.5.5.1, 10.5.5.2, 10.5.5.3 — fixed in 10.5.2.12, 10.5.3.8, 10.5.4.8
How to fix
Upgrade to a fixed version: Dell SmartFabric OS10 Software 10.5.2.12, 10.5.3.8, 10.5.4.8. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000216584/dsa-2023-124-security-update-for-dell-smartfabric-os10-multiple-vulnerabilities
- https://www.dell.com/support/kbdoc/en-us/000216584/dsa-2023-124-security-update-for-dell-smartfabric-os10-multiple-vulnerabilities
Get alerted when CVE-2023-28078 or the next vulnerability affects your stack