What’s Vulnerable › Vulnerabilities
CVE-2023-28097: OpenSIPS has vulnerability in the Content-Length Parser
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-15 · updated 2026-06-17
- Weakness: CWE-190
Description
OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.9 and 3.2.6, a malformed SIP message containing a large _Content-Length_ value and a specially crafted Request-URI causes a segmentation fault in OpenSIPS. This issue occurs when a large amount of shared memory using the `-m` flag was allocated to OpenSIPS, such as 10 GB of RAM. On the test system, this issue occurred when shared memory was set to `2362` or higher. This issue is fixed in versions 3.1.9 and 3.2.6. The only workaround is to guarantee that the Content-Length value of input messages is never larger than `2147483647`.
Affected products
- opensips: before 3.1.9; from 3.2.0 before 3.2.6 — fixed in 3.1.9, 3.2.6
How to fix
Upgrade to a fixed version: opensips 3.1.9, 3.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/OpenSIPS/opensips/commit/7cab422e2fc648f910abba34f3f0dbb3ae171ff5
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-c6j5-f4h4-2xrq
- https://opensips.org/pub/audit-2022/opensips-audit-technical-report-full.pdf
- https://github.com/OpenSIPS/opensips/commit/7cab422e2fc648f910abba34f3f0dbb3ae171ff5
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-c6j5-f4h4-2xrq
- https://opensips.org/pub/audit-2022/opensips-audit-technical-report-full.pdf
Get alerted when CVE-2023-28097 or the next vulnerability affects your stack