What’s Vulnerable › Vulnerabilities
CVE-2023-28098: OpenSIPS has vulnerability in the Digest Authentication Parser
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-15 · updated 2026-06-17
- Weakness: CWE-20
Description
OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.7 and 3.2.4, a specially crafted Authorization header causes OpenSIPS to crash or behave in an unexpected way due to a bug in the function `parse_param_name()` . This issue was discovered while performing coverage guided fuzzing of the function parse_msg. The AddressSanitizer identified that the issue occurred in the function `q_memchr()` which is being called by the function `parse_param_name()`. This issue may cause erratic program behaviour or a server crash. It affects configurations containing functions that make use of the affected code, such as the function `www_authorize()` . Versions 3.1.7 and 3.2.4 contain a fix.
Affected products
- opensips: before 3.1.7; from 3.2.0 before 3.2.4 — fixed in 3.1.7, 3.2.4
How to fix
Upgrade to a fixed version: opensips 3.1.7, 3.2.4. Check the vendor advisory for mitigations.
References
- https://github.com/OpenSIPS/opensips/commit/dd9141b6f67d7df4072f3430f628d4b73df5e102
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-jrqg-vppj-hr2h
- https://opensips.org/pub/audit-2022/opensips-audit-technical-report-full.pdf
- https://github.com/OpenSIPS/opensips/commit/dd9141b6f67d7df4072f3430f628d4b73df5e102
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-jrqg-vppj-hr2h
- https://opensips.org/pub/audit-2022/opensips-audit-technical-report-full.pdf
Get alerted when CVE-2023-28098 or the next vulnerability affects your stack