What’s Vulnerable › Vulnerabilities
CVE-2023-28099: OpenSIPS has vulnerability in the ds_is_in_list() function
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-15 · updated 2026-06-17
- Weakness: CWE-20
Description
OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.9 and 3.2.6, if `ds_is_in_list()` is used with an invalid IP address string (`NULL` is illegal input), OpenSIPS will attempt to print a string from a random address (stack garbage), which could lead to a crash. All users of `ds_is_in_list()` without the `$si` variable as 1st parameter could be affected by this vulnerability to a larger, lesser or no extent at all, depending if the data passed to the function is a valid IPv4 or IPv6 address string or not. Fixes will are available starting with the 3.1.9 and 3.2.6 minor releases. There are no known workarounds.
Affected products
- opensips: before 3.1.9; from 3.2.0 before 3.2.6 — fixed in 3.1.9, 3.2.6
How to fix
Upgrade to a fixed version: opensips 3.1.9, 3.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/OpenSIPS/opensips/commit/e2f13d374
- https://github.com/OpenSIPS/opensips/issues/2780
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-pfm5-6vhv-3ff3
- https://github.com/OpenSIPS/opensips/commit/e2f13d374
- https://github.com/OpenSIPS/opensips/issues/2780
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-pfm5-6vhv-3ff3
Get alerted when CVE-2023-28099 or the next vulnerability affects your stack