What’s Vulnerable › Vulnerabilities
CVE-2023-28100: TIOCLINUX can send commands outside sandbox if running on a virtual console
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-16 · updated 2026-06-17
- Weakness: CWE-20
Description
Flatpak is a system for building, distributing, and running sandboxed desktop applications on Linux. Versions prior to 1.10.8, 1.12.8, 1.14.4, and 1.15.4 contain a vulnerability similar to CVE-2017-5226, but using the `TIOCLINUX` ioctl command instead of `TIOCSTI`. If a Flatpak app is run on a Linux virtual console such as `/dev/tty1`, it can copy text from the virtual console and paste it into the command buffer, from which the command might be run after the Flatpak app has exited. Ordinary graphical terminal emulators like xterm, gnome-terminal and Konsole are unaffected. This vulnerability is specific to the Linux virtual consoles `/dev/tty1`, `/dev/tty2` and so on. A patch is available in versions 1.10.8, 1.12.8, 1.14.4, and 1.15.4. As a workaround, don't run Flatpak on a Linux virtual console. Flatpak is primarily designed to be used in a Wayland or X11 graphical environment.
Affected products
- flatpak: before 1.10.8; from 1.12.0 before 1.12.8; from 1.14.0 before 1.14.4; from 1.15.0 before 1.15.4 — fixed in 1.10.8, 1.12.8, 1.14.4, 1.15.4
How to fix
Upgrade to a fixed version: flatpak 1.10.8, 1.12.8, 1.14.4, 1.15.4. Check the vendor advisory for mitigations.
References
- https://github.com/flatpak/flatpak/commit/8e63de9a7d3124f91140fc74f8ca9ed73ed53be9
- https://github.com/flatpak/flatpak/security/advisories/GHSA-7qpw-3vjv-xrqp
- https://marc.info/?l=oss-security&m=167879021709955&w=2
- https://security.gentoo.org/glsa/202312-12
- https://github.com/flatpak/flatpak/commit/8e63de9a7d3124f91140fc74f8ca9ed73ed53be9
- https://github.com/flatpak/flatpak/security/advisories/GHSA-7qpw-3vjv-xrqp
- https://marc.info/?l=oss-security&m=167879021709955&w=2
- https://security.gentoo.org/glsa/202312-12
Get alerted when CVE-2023-28100 or the next vulnerability affects your stack