What’s Vulnerable › Vulnerabilities
CVE-2023-28101: Flatpak metadata with ANSI control codes can cause misleading terminal output
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-16 · updated 2026-06-17
- Weakness: CWE-116
Description
Flatpak is a system for building, distributing, and running sandboxed desktop applications on Linux. In versions prior to 1.10.8, 1.12.8, 1.14.4, and 1.15.4, if an attacker publishes a Flatpak app with elevated permissions, they can hide those permissions from users of the `flatpak(1)` command-line interface by setting other permissions to crafted values that contain non-printable control characters such as `ESC`. A fix is available in versions 1.10.8, 1.12.8, 1.14.4, and 1.15.4. As a workaround, use a GUI like GNOME Software rather than the command-line interface, or only install apps whose maintainers you trust.
Affected products
- flatpak: before 1.10.8; from 1.12.0 before 1.12.8; from 1.14.0 before 1.14.4; from 1.15.0 before 1.15.4 — fixed in 1.10.8, 1.12.8, 1.14.4, 1.15.4
How to fix
Upgrade to a fixed version: flatpak 1.10.8, 1.12.8, 1.14.4, 1.15.4. Check the vendor advisory for mitigations.
References
- https://github.com/flatpak/flatpak/commit/409e34187de2b2b2c4ef34c79f417be698830f6c
- https://github.com/flatpak/flatpak/commit/6cac99dafe6003c8a4bd5666341c217876536869
- https://github.com/flatpak/flatpak/commit/7fe63f2e8f1fd2dafc31d45154cf0b191ebec66c
- https://github.com/flatpak/flatpak/security/advisories/GHSA-h43h-fwqx-mpp8
- https://security.gentoo.org/glsa/202312-12
- https://github.com/flatpak/flatpak/commit/409e34187de2b2b2c4ef34c79f417be698830f6c
- https://github.com/flatpak/flatpak/commit/6cac99dafe6003c8a4bd5666341c217876536869
- https://github.com/flatpak/flatpak/commit/7fe63f2e8f1fd2dafc31d45154cf0b191ebec66c
- https://github.com/flatpak/flatpak/security/advisories/GHSA-h43h-fwqx-mpp8
- https://security.gentoo.org/glsa/202312-12
Get alerted when CVE-2023-28101 or the next vulnerability affects your stack