What’s Vulnerable › Vulnerabilities
CVE-2023-28106: Pimcore vulnerable to Cross-site Scripting in UrlSlug Data type
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-16 · updated 2026-06-17
- Weakness: CWE-79
Description
Pimcore is an open source data and experience management platform. Prior to version 10.5.19, an attacker can use cross-site scripting to send a malicious script to an unsuspecting user. Users may upgrade to version 10.5.19 to receive a patch or, as a workaround, apply the patch manually.
Affected products
- pimcore/pimcore: before 10.5.19 — fixed in 10.5.19
How to fix
Upgrade to a fixed version: pimcore/pimcore 10.5.19. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/c59d0bf1d03a5037b586fe06230694fa3818dbf2
- https://github.com/pimcore/pimcore/pull/14669.patch
- https://github.com/pimcore/pimcore/security/advisories/GHSA-x5j3-mq9g-8jc8
- https://huntr.dev/bounties/fa77d780-9b23-404b-8c44-12108881d11a
- https://github.com/pimcore/pimcore/commit/c59d0bf1d03a5037b586fe06230694fa3818dbf2
- https://github.com/pimcore/pimcore/pull/14669.patch
- https://github.com/pimcore/pimcore/security/advisories/GHSA-x5j3-mq9g-8jc8
- https://huntr.dev/bounties/fa77d780-9b23-404b-8c44-12108881d11a
Get alerted when CVE-2023-28106 or the next vulnerability affects your stack