What’s Vulnerable › Vulnerabilities
CVE-2023-28107: Discourse vulnerable to multisite DoS by spamming backups
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-17 · updated 2026-06-17
- Weakness: CWE-770
Description
Discourse is an open-source discussion platform. Prior to version 3.0.2 of the `stable` branch and version 3.1.0.beta3 of the `beta` and `tests-passed` branches, a user logged as an administrator can request backups multiple times, which will eat up all the connections to the DB. If this is done on a site using multisite, then it can affect the whole cluster. The vulnerability is patched in version 3.0.2 of the `stable` branch and version 3.1.0.beta3 of the `beta` and `tests-passed` branches. There are no known workarounds.
Affected products
- discourse: through 3.0.1; before 3.1.0; 3.1.0-beta1, 3.1.0-beta2 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: discourse 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/0bd64788d2b4680c04fbef76314a24884d65fed9
- https://github.com/discourse/discourse/commit/78a3efa7104eed6dd3ed7a06a71e2705337d9e61
- https://github.com/discourse/discourse/pull/20700
- https://github.com/discourse/discourse/pull/20701
- https://github.com/discourse/discourse/security/advisories/GHSA-cp7c-fm4c-6xxx
- https://github.com/discourse/discourse/commit/0bd64788d2b4680c04fbef76314a24884d65fed9
- https://github.com/discourse/discourse/commit/78a3efa7104eed6dd3ed7a06a71e2705337d9e61
- https://github.com/discourse/discourse/pull/20700
- https://github.com/discourse/discourse/pull/20701
- https://github.com/discourse/discourse/security/advisories/GHSA-cp7c-fm4c-6xxx
Get alerted when CVE-2023-28107 or the next vulnerability affects your stack