What’s Vulnerable › Vulnerabilities
CVE-2023-28110: JumpServer Koko vulnerable to Command Injection for Kubernetes Connection
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-16 · updated 2026-06-17
- Weakness: CWE-77
Description
Jumpserver is a popular open source bastion host, and Koko is a Jumpserver component that is the Go version of coco, refactoring coco's SSH/SFTP service and Web Terminal service. Prior to version 2.28.8, using illegal tokens to connect to a Kubernetes cluster through Koko can result in the execution of dangerous commands that may disrupt the Koko container environment and affect normal usage. The vulnerability has been fixed in v2.28.8.
Affected products
- jumpserver: before 2.28.8 — fixed in 2.28.8
- fit2cloud Koko: all versions
How to fix
Upgrade to a fixed version: jumpserver 2.28.8. Check the vendor advisory for mitigations.
References
- https://github.com/jumpserver/jumpserver/releases/tag/v2.28.8
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-6x5p-jm59-jh29
- https://github.com/jumpserver/jumpserver/releases/tag/v2.28.8
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-6x5p-jm59-jh29
Get alerted when CVE-2023-28110 or the next vulnerability affects your stack