What’s Vulnerable › Vulnerabilities
CVE-2023-28111: Discourse vulnerable to SSRF protection bypass possible with IPv4-mapped IPv6 addresses
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-17 · updated 2026-06-17
- Weakness: CWE-918
Description
Discourse is an open-source discussion platform. Prior to version 3.1.0.beta3 of the `beta` and `tests-passed` branches, attackers are able to bypass Discourse's server-side request forgery (SSRF) protection for private IPv4 addresses by using a IPv4-mapped IPv6 address. The issue is patched in the latest beta and tests-passed version of Discourse. version 3.1.0.beta3 of the `beta` and `tests-passed` branches. There are no known workarounds.
Affected products
- discourse: before 3.1.0; 3.1.0-beta1, 3.1.0-beta2 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: discourse 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/fd16eade7fcc6bba4b71e71106a2eb13cdfdae4a
- https://github.com/discourse/discourse/pull/20710
- https://github.com/discourse/discourse/security/advisories/GHSA-26h3-8ww8-v5fc
- https://github.com/discourse/discourse/commit/fd16eade7fcc6bba4b71e71106a2eb13cdfdae4a
- https://github.com/discourse/discourse/pull/20710
- https://github.com/discourse/discourse/security/advisories/GHSA-26h3-8ww8-v5fc
Get alerted when CVE-2023-28111 or the next vulnerability affects your stack