What’s Vulnerable › Vulnerabilities
CVE-2023-28112: Discourse's SSRF protection missing for some FastImage requests
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-17 · updated 2026-06-17
- Weakness: CWE-918
Description
Discourse is an open-source discussion platform. Prior to version 3.1.0.beta3 of the `beta` and `tests-passed` branches, some user provided URLs were being passed to FastImage without SSRF protection. Insufficient protections could enable attackers to trigger outbound network connections from the Discourse server to private IP addresses. This affects any site running the `tests-passed` or `beta` branches versions 3.1.0.beta2 and prior. This issue is patched in version 3.1.0.beta3 of the `beta` and `tests-passed` branches. There are no known workarounds.
Affected products
- discourse: before 3.1.0; through 3.1.0; 3.1.0-beta1, 3.1.0-beta2 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: discourse 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/39c2f63b35d90ebaf67b9604cf1d424e5984203c
- https://github.com/discourse/discourse/pull/20710
- https://github.com/discourse/discourse/security/advisories/GHSA-9897-x229-55gh
- https://github.com/discourse/discourse/commit/39c2f63b35d90ebaf67b9604cf1d424e5984203c
- https://github.com/discourse/discourse/pull/20710
- https://github.com/discourse/discourse/security/advisories/GHSA-9897-x229-55gh
Get alerted when CVE-2023-28112 or the next vulnerability affects your stack