What’s Vulnerable › Vulnerabilities

CVE-2023-28113: russh may use insecure Diffie-Hellman keys

Description

russh is a Rust SSH client and server library. Starting in version 0.34.0 and prior to versions 0.36.2 and 0.37.1, Diffie-Hellman key validation is insufficient, which can lead to insecure shared secrets and therefore breaks confidentiality. Connections between a russh client and server or those of a russh peer with some other misbehaving peer are most likely to be problematic. These may vulnerable to eavesdropping. Most other implementations reject such keys, so this is mainly an interoperability issue in such a case. This issue is fixed in versions 0.36.2 and 0.37.1

Affected products

How to fix

Upgrade to a fixed version: warp-tech russh 0.36.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-28113 or the next vulnerability affects your stack