What’s Vulnerable › Vulnerabilities
CVE-2023-28114: `cilium-cli` disables etcd authorization for clustermesh clusters
- Severity: medium (CVSS 4.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-22 · updated 2026-06-17
- Weakness: CWE-280
Description
`cilium-cli` is the command line interface to install, manage, and troubleshoot Kubernetes clusters running Cilium. Prior to version 0.13.2,`cilium-cli`, when used to configure cluster mesh functionality, can remove the enforcement of user permissions on the `etcd` store used to mirror local cluster information to remote clusters. Users who have set up cluster meshes using the Cilium Helm chart are not affected by this issue. Due to an incorrect mount point specification, the settings specified by the `initContainer` that configures `etcd` users and their permissions are overwritten when using `cilium-cli` to configure a cluster mesh. An attacker who has already gained access to a valid key and certificate for an `etcd` cluster compromised in this manner could then modify state in that `etcd` cluster. This issue is patched in `cilium-cli` 0.13.2. As a workaround, one may use Cilium's Helm charts to create their cluster.
Affected products
- cilium-cli: before 0.13.2 — fixed in 0.13.2
How to fix
Upgrade to a fixed version: cilium-cli 0.13.2. Check the vendor advisory for mitigations.
References
- https://artifacthub.io/packages/helm/cilium/cilium
- https://github.com/cilium/cilium-cli/commit/fb1427025764e1eebc4a7710d902c4f22cae2610
- https://github.com/cilium/cilium-cli/releases/tag/v0.13.2
- https://github.com/cilium/cilium-cli/security/advisories/GHSA-6f27-3p6c-p5jc
- https://artifacthub.io/packages/helm/cilium/cilium
- https://github.com/cilium/cilium-cli/commit/fb1427025764e1eebc4a7710d902c4f22cae2610
- https://github.com/cilium/cilium-cli/releases/tag/v0.13.2
- https://github.com/cilium/cilium-cli/security/advisories/GHSA-6f27-3p6c-p5jc
Get alerted when CVE-2023-28114 or the next vulnerability affects your stack