What’s Vulnerable › Vulnerabilities
CVE-2023-28121
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 87.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-12 · updated 2026-06-17
- Weakness: CWE-287
Description
An issue in WooCommerce Payments plugin for WordPress (versions 5.6.1 and lower) allows an unauthenticated attacker to send requests on behalf of an elevated user, like administrator. This allows a remote, unauthenticated attacker to gain admin access on a site that has the affected version of the plugin activated.
Affected products
- Automattic Woocommerce Payments: from 4.8.0 before 4.8.2; from 5.0.0 before 5.0.4; from 5.1.0 before 5.1.3; from 5.2.0 before 5.2.2; from 5.5.0 before 5.5.2 — fixed in 4.8.2, 5.0.4, 5.1.3, 5.2.2, 5.5.2
- Automattic WooPayments – Fully Integrated Solution Built and Supported by Woo: from 5.6.0 before 5.6.2; 4.9.0, 5.3.0, 5.4.0 — fixed in 5.6.2
How to fix
Upgrade to a fixed version: Automattic Woocommerce Payments 4.8.2, 5.0.4, 5.1.3, 5.2.2; Automattic WooPayments – Fully Integrated Solution Built and Supported by Woo 5.6.2. Check the vendor advisory for mitigations.
References
- https://developer.woocommerce.com/2023/03/23/critical-vulnerability-detected-in-woocommerce-payments-what-you-need-to-know/
- https://www.rcesecurity.com/2023/07/patch-diffing-cve-2023-28121-to-compromise-a-woocommerce/
- https://developer.woocommerce.com/2023/03/23/critical-vulnerability-detected-in-woocommerce-payments-what-you-need-to-know/
- https://www.rcesecurity.com/2023/07/patch-diffing-cve-2023-28121-to-compromise-a-woocommerce/
Get alerted when CVE-2023-28121 or the next vulnerability affects your stack