What’s Vulnerable › Vulnerabilities
CVE-2023-2816: Consul Envoy Extension Downsteam Proxy Configuration By Upstream Service Owner
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-02 · updated 2026-06-17
- Weakness: CWE-266
Description
Consul and Consul Enterprise allowed any user with service:write permissions to use Envoy extensions configured via service-defaults to patch remote proxy instances that target the configured service, regardless of whether the user has permission to modify the service(s) corresponding to those modified proxies.
Affected products
- HashiCorp Consul: from 1.15.0 before 1.15.3 — fixed in 1.15.3
How to fix
Upgrade to a fixed version: HashiCorp Consul 1.15.3. Check the vendor advisory for mitigations.
References
- https://discuss.hashicorp.com/t/hcsec-2023-16-consul-envoy-extension-downstream-proxy-configuration-by-upstream-service-owner/54525
- https://discuss.hashicorp.com/t/hcsec-2023-16-consul-envoy-extension-downstream-proxy-configuration-by-upstream-service-owner/54525
Get alerted when CVE-2023-2816 or the next vulnerability affects your stack