What’s Vulnerable › Vulnerabilities
CVE-2023-28325
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-11 · updated 2026-10-24
- Weakness: CWE-285
Description
An improper authorization vulnerability exists in Rocket.Chat <6.0 that could allow a hacker to manipulate the rid parameter and change the updateMessage method that only checks whether the user is allowed to edit message in the target room.
Affected products
- Rocket.Chat: before 6.0.0 — fixed in 6.0.0
How to fix
Upgrade to a fixed version: Rocket.Chat 6.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-28325 or the next vulnerability affects your stack