What’s Vulnerable › Vulnerabilities
CVE-2023-28330: Moodle: authenticated arbitrary file read through malformed backup file
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-23 · updated 2026-06-17
- Weakness: CWE-20
Description
Insufficient sanitizing in backup resulted in an arbitrary file read risk. The capability to access this feature is only available to teachers, managers and admins by default.
Affected products
- Moodle: from 3.9.0 (excl.) before 3.9.20; from 3.11.0 (excl.) before 3.11.13; from 4.0.0 (excl.) before 4.0.7; 3.9.0, 3.11.0, 4.0.0, 4.1.0, 4.1.1 — fixed in 3.11.13, 3.9.20, 4.0.7
How to fix
Upgrade to a fixed version: Moodle 3.11.13, 3.9.20, 4.0.7. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2179412
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3QZN34VSF4HTCW3C3ZP2OZYSLYUKADPF/
- https://moodle.org/mod/forum/discuss.php?d=445062
- https://bugzilla.redhat.com/show_bug.cgi?id=2179412
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3QZN34VSF4HTCW3C3ZP2OZYSLYUKADPF/
- https://moodle.org/mod/forum/discuss.php?d=445062
Get alerted when CVE-2023-28330 or the next vulnerability affects your stack