What’s Vulnerable › Vulnerabilities
CVE-2023-28362: Actionpack has possible cross-site scripting vulnerability via User Supplied Values to redirect_to
- Severity: medium (CVSS 4.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-09 · updated 2026-06-17
- Weakness: CWE-116
Description
The redirect_to method in Rails allows provided values to contain characters which are not legal in an HTTP header value. This results in the potential for downstream services which enforce RFC compliance on HTTP response headers to remove the assigned Location header.
Affected products
- Rubygems Actionpack: before 6.1.7.4; from 7.0.0 before 7.0.5.1; 0.9.0, 0.9.5, 1.0.0, 1.0.1, 1.1.0, 1.10.1 (+433) — fixed in 6.1.7.4, 7.0.5.1
- Rails Action Pack: from 7.0.5.1 before 7.0.5.1; from 6.1.7.4 before 6.1.7.4 — fixed in 6.1.7.4, 7.0.5.1
How to fix
Upgrade to a fixed version: Rubygems Actionpack 6.1.7.4, 7.0.5.1; Rails Action Pack 6.1.7.4, 7.0.5.1. Check the vendor advisory for mitigations.
References
- https://discuss.rubyonrails.org/t/cve-2023-28362-possible-xss-via-user-supplied-values-to-redirect-to/83132
- https://github.com/advisories/GHSA-4g8v-vg43-wpgf
- https://github.com/rails/rails/commit/1c3f93d1e90a3475f9ae2377ead25ccf11f71441
- https://github.com/rails/rails/commit/69e37c84e3f77d75566424c7d0015172d6a6fac5
- https://security.netapp.com/advisory/ntap-20250502-0009/
Get alerted when CVE-2023-28362 or the next vulnerability affects your stack