What’s Vulnerable › Vulnerabilities
CVE-2023-2837: Stack-based Buffer Overflow in gpac/gpac
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-22 · updated 2026-06-17
- Weakness: CWE-121
Description
Stack-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.2.2.
Affected products
- GPAC: before 2.2.2 — fixed in 2.2.2
How to fix
Upgrade to a fixed version: GPAC 2.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/gpac/gpac/commit/6f28c4cd607d83ce381f9b4a9f8101ca1e79c611
- https://huntr.dev/bounties/a6bfd1b2-aba8-4c6f-90c4-e95b1831cb17
- https://www.debian.org/security/2023/dsa-5411
- https://github.com/gpac/gpac/commit/6f28c4cd607d83ce381f9b4a9f8101ca1e79c611
- https://huntr.dev/bounties/a6bfd1b2-aba8-4c6f-90c4-e95b1831cb17
- https://www.debian.org/security/2023/dsa-5411
Get alerted when CVE-2023-2837 or the next vulnerability affects your stack