What’s Vulnerable › Vulnerabilities
CVE-2023-28394
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-23 · updated 2026-06-17
- Weakness: CWE-78
Description
Beekeeper Studio versions prior to 3.9.9 allows a remote authenticated attacker to execute arbitrary JavaScript code with the privilege of the application on the PC where the affected product is installed. As a result, an arbitrary OS command may be executed as well.
Affected products
- Beekeeper Studio, Inc. Beekeeper Studio: before 3.9.9 — fixed in 3.9.9
How to fix
Upgrade to a fixed version: Beekeeper Studio, Inc. Beekeeper Studio 3.9.9. Check the vendor advisory for mitigations.
References
- https://github.com/beekeeper-studio/beekeeper-studio
- https://jvn.jp/en/jp/JVN11705010/
- https://www.beekeeperstudio.io/
- https://github.com/beekeeper-studio/beekeeper-studio
- https://jvn.jp/en/jp/JVN11705010/
- https://www.beekeeperstudio.io/
Get alerted when CVE-2023-28394 or the next vulnerability affects your stack