What’s Vulnerable › Vulnerabilities
CVE-2023-28424: Soko SQL Injection vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-20 · updated 2026-06-17
- Weakness: CWE-89
Description
Soko if the code that powers packages.gentoo.org. Prior to version 1.0.2, the two package search handlers, `Search` and `SearchFeed`, implemented in `pkg/app/handler/packages/search.go`, are affected by a SQL injection via the `q` parameter. As a result, unauthenticated attackers can execute arbitrary SQL queries on `https://packages.gentoo.org/`. It was also demonstrated that primitive was enough to gain code execution in the context of the PostgreSQL container. The issue was addressed in commit `4fa6e4b619c0362728955b6ec56eab0e0cbf1e23y` of version 1.0.2 using prepared statements to interpolate user-controlled data in SQL queries.
Affected products
- gentoo soko: before 1.0.2 — fixed in 1.0.2
How to fix
Upgrade to a fixed version: gentoo soko 1.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/gentoo/soko/security/advisories/GHSA-gc2x-86p3-mxg2
- https://gitweb.gentoo.org/sites/soko.git/commit/?id=4fa6e4b619c0362728955b6ec56eab0e0cbf1e23
- https://www.sonarsource.com/blog/why-orms-and-prepared-statements-cant-always-win
- https://github.com/gentoo/soko/security/advisories/GHSA-gc2x-86p3-mxg2
- https://gitweb.gentoo.org/sites/soko.git/commit/?id=4fa6e4b619c0362728955b6ec56eab0e0cbf1e23
Get alerted when CVE-2023-28424 or the next vulnerability affects your stack