What’s Vulnerable › Vulnerabilities
CVE-2023-28428: PDFio vulnerable to Denial Of Service when opening a corrupt PDF file
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-20 · updated 2026-06-17
- Weakness: CWE-770
Description
PDFio is a C library for reading and writing PDF files. In versions 1.1.0 and prior, a denial of service vulnerability exists in the pdfio parser. Crafted pdf files can cause the program to run at 100% utilization and never terminate. This is different from CVE-2023-24808. A patch for this issue is available in version 1.1.1.
Affected products
- michaelrsweet pdfio: before 1.1.1 — fixed in 1.1.1
How to fix
Upgrade to a fixed version: michaelrsweet pdfio 1.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/michaelrsweet/pdfio/commit/97d4955666779dc5b0665e15dd951a5c12426a31
- https://github.com/michaelrsweet/pdfio/security/advisories/GHSA-68x8-9phf-j7jf
- https://github.com/michaelrsweet/pdfio/commit/97d4955666779dc5b0665e15dd951a5c12426a31
- https://github.com/michaelrsweet/pdfio/security/advisories/GHSA-68x8-9phf-j7jf
Get alerted when CVE-2023-28428 or the next vulnerability affects your stack