What’s Vulnerable › Vulnerabilities
CVE-2023-28430: OneSignal repository github action command injection
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-27 · updated 2026-06-17
- Weakness: CWE-77
Description
OneSignal is an email, sms, push notification, and in-app message service for mobile apps.The Zapier.yml workflow is triggered on issues (types: [closed]) (i.e., when an Issue is closed). The workflow starts with full write-permissions GitHub repository token since the default workflow permissions on Organization/Repository level are set to read-write. This workflow runs the following step with data controlled by the comment `(${{ github.event.issue.title }} – the full title of the Issue)`, allowing an attacker to take over the GitHub Runner and run custom commands, potentially stealing any secret (if used), or altering the repository. This issue was found with CodeQL using javascript’s Expression injection in Actions query. This issue has been addressed in the repositories github action. No actions are required by users. This issue is also tracked as `GHSL-2023-051`.
Affected products
- OneSignal react-native-onesignal: before 4.5.1 — fixed in 4.5.1
How to fix
Upgrade to a fixed version: OneSignal react-native-onesignal 4.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/OneSignal/react-native-onesignal/commit/4a66f4237fb51dcc2236889038d488cd49b0f433
- https://github.com/OneSignal/react-native-onesignal/commit/4e43bda4ce1eb395f36bb8a5640002523c051085
- https://securitylab.github.com/advisories/GHSL-2023-051_React_Native_OneSignal_SDK/
- https://github.com/OneSignal/react-native-onesignal/commit/4a66f4237fb51dcc2236889038d488cd49b0f433
- https://github.com/OneSignal/react-native-onesignal/commit/4e43bda4ce1eb395f36bb8a5640002523c051085
- https://securitylab.github.com/advisories/GHSL-2023-051_React_Native_OneSignal_SDK/
Get alerted when CVE-2023-28430 or the next vulnerability affects your stack