What’s Vulnerable › Vulnerabilities
CVE-2023-28437: SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-25 · updated 2026-06-17
- Weakness: CWE-89
Description
Dataease is an open source data visualization and analysis tool. The blacklist for SQL injection protection is missing entries. This vulnerability has been fixed in version 1.18.5. There are no known workarounds.
Affected products
- dataease: before 1.18.5 — fixed in 1.18.5
How to fix
Upgrade to a fixed version: dataease 1.18.5. Check the vendor advisory for mitigations.
References
- https://github.com/dataease/dataease/issues/4795
- https://github.com/dataease/dataease/releases/tag/v1.18.5
- https://github.com/dataease/dataease/security/advisories/GHSA-7j7j-9rw6-3r56
- https://github.com/dataease/dataease/issues/4795
- https://github.com/dataease/dataease/releases/tag/v1.18.5
- https://github.com/dataease/dataease/security/advisories/GHSA-7j7j-9rw6-3r56
Get alerted when CVE-2023-28437 or the next vulnerability affects your stack