What’s Vulnerable › Vulnerabilities
CVE-2023-28438: Pimcore vulnerable to improper quoting of filters in Custom Reports
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-22 · updated 2026-06-17
- Weakness: CWE-89
Description
Pimcore is an open source data and experience management platform. Prior to version 10.5.19, since a user with 'report' permission can already write arbitrary SQL queries and given the fact that this endpoint is using the GET method (no CSRF protection), an attacker can inject an arbitrary query by manipulating a user to click on a link. Users should upgrade to version 10.5.19 to receive a patch or, as a workaround, may apply the patch manually.
Affected products
- pimcore/pimcore: before 10.5.19 — fixed in 10.5.19
How to fix
Upgrade to a fixed version: pimcore/pimcore 10.5.19. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/d1abadb181c88ebaa4bce1916f9077469d4ea2bc.patch
- https://github.com/pimcore/pimcore/pull/14526
- https://github.com/pimcore/pimcore/security/advisories/GHSA-vf7q-g2pv-jxvx
- https://github.com/pimcore/pimcore/commit/d1abadb181c88ebaa4bce1916f9077469d4ea2bc.patch
- https://github.com/pimcore/pimcore/pull/14526
- https://github.com/pimcore/pimcore/security/advisories/GHSA-vf7q-g2pv-jxvx
Get alerted when CVE-2023-28438 or the next vulnerability affects your stack